PHP slik du vil ha det

PHP slik du vil ha det

Vi er et av de få stedene som tilbyr den nye PHP versjonen 7.0 som standard. Du kan også fritt velge enten den nyere PHP 7.0 eller de eldre mer kompatible PHP 5.6, 5.5, 5.4, 5.3 eller 5.2. Alle populære PHP-baserte CMSer som Wordpress, Joomla, og Drupal, kjører uten feil takket være vår justerbare konfigurasjon og få begrensninger.

Skreddersydd PHP til deg

Noen PHP-systemer krever særlig omsorg. Det kan f.eks være at det er behov for å justere den maksimale størrelsen på filer som kan lastes opp - eller at scriptet skal kjøre i "safe mode". Disse tingene kan du selv konfigurere i kontrollsenteret ved å opprette en "php.ini"-fil. Endringen vil tre i kraft med det samme.

Nesten ingen begrensninger

Scripts og applikasjoner kan yte optimalt og har masse albuerom. Vi tillater et stort ressursforbruk - f.eks er standardmengde hukommelse for PHP scripts 256 MB, men den kan settes helt opp til 512 MB. På samme måte kan du laste opp filer på opp til 512 MB størrelse via PHP. Se alle ressursbegrensninger.

Mange utvidelser

Som standard tilbyr vi et hav av utvidelser som gir deg kraftige verktøy til f.eks å manipulere bilde- eller Flashfiler, adgang til PDO-databaseabstraheringslag, koble til IMAP-, FTP-, SNMP-, PostgreSQL- eller LDAP- servere. Se alle våre utvidelser.

Høy sikkerhet

Som standard kjører alle våre PHP-prosesser isolert fra andre brukere og med egne privilegier (også kjent som "i en sankasse"). Dette gir økt sikkerhet framfor å kjøre alt under samme bruker - da sikkerheten ligger på et langt høyere nivå. Dessuten følger PHP-utvidelsen "suhosin" med, som beskytter hjemmesiden din mot typiske angrep.